It is currently Thu Nov 23, 2017 3:25 pm

All times are UTC - 8 hours [ DST ]





Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Earthquaker Avalanche Run and Eventide H9
PostPosted: Wed Jul 12, 2017 10:55 am 
Offline

Joined: Wed Jul 12, 2017 10:04 am
Posts: 1
Searched all over and can't find an answer to this: has anyone successfully powered an Avalanche Run with a VL supply? The specs say it has a 425ma draw.

Will one of the 400ma outs on a 4x4 work? Or should I use a current doubler to combine one of the 400ma and one of the 100ma outs?
I'm also trying to power an H9 which requires 500ma (also center positive 2.5mm). If I did the same thing with that I'd use up half my outs just with those two pedals which would leave me short for the rest of my board.

Do I need to look at a Mondo?
Any other options that would just involve using one output for each?
Or maybe the easiest thing is a small power strip and use the AC jack for these two pedals...


Top
 Profile  
 
 Post subject: Re: Earthquaker Avalanche Run and Eventide H9
PostPosted: Mon Jul 17, 2017 9:49 am 
Offline

Joined: Tue May 05, 2009 2:33 pm
Posts: 6760
Location: The Lab
I just measured an Avalanche Run to be certain, and I have previously measured an H9 with the Max update. Each of these will be perfectly fine to power from a single 400mA output. They each actually draw less than 400mA.

I hope that helps!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: