PX8+ insert loop problem

Q & A for building and interfacing your rack gear with Ground Control Pro and GCX-based systems.
Post Reply
TGrubb1
Posts: 5
Joined: Fri Sep 08, 2017 12:37 pm

PX8+ insert loop problem

Post by TGrubb1 » Fri Sep 08, 2017 12:44 pm

Hey guys
I just set up my PX8+ loop switcher on my board. When I insert any jack into the input or output of the insert loop, the whole system will shut all sound off. Im running a volume pedal and a boost out of that insert loop between loops 6/7. I have tried just running the volume pedal and nothing else changed. I dont know what the problem is.
Thanks, Ty

JohnClark
Posts: 7127
Joined: Tue May 05, 2009 2:33 pm
Location: The Lab

Re: PX8+ insert loop problem

Post by JohnClark » Fri Sep 08, 2017 8:32 pm

If you wanted your volume pedal in the Insert you would need to connect the Insert Send to the Volume Pedal Input, and the Volume Pedal Output to the Insert Return. Is that what you are doing?

TGrubb1
Posts: 5
Joined: Fri Sep 08, 2017 12:37 pm

Re: PX8+ insert loop problem

Post by TGrubb1 » Fri Sep 08, 2017 8:52 pm

yes sir thats what I am doing. It doesn't even read any signal once i put any input jack into the insert slot. It automatically just shuts off all signal.

JohnClark
Posts: 7127
Joined: Tue May 05, 2009 2:33 pm
Location: The Lab

Re: PX8+ insert loop problem

Post by JohnClark » Fri Sep 08, 2017 9:18 pm

TGrubb1 wrote:yes sir thats what I am doing. It doesn't even read any signal once i put any input jack into the insert slot. It automatically just shuts off all signal.
Unless you complete the path back to the Return, connecting only to the Send will stop any signal from the Input and loops 1-6 from reaching the final output.

As a test, try the following...

1. Connect your Guitar to the Input.
2. Connect a patch cable from the Insert Send to the Insert Return.
3. Connect the Output to the Instrument Input on your amp.
With all Loops turned Off, you should hear your guitar thru the amp. Does this work?

Post Reply