Voodoo Lab
http://www.voodoolab.com/forum/

Multi GCX loops turning on and off problem
http://www.voodoolab.com/forum/viewtopic.php?f=9&t=8371
Page 1 of 1

Author:  roybeukers [ Tue Aug 29, 2017 1:46 pm ]
Post subject:  Multi GCX loops turning on and off problem

Hi guys, I have a new problem/question on which I hope you can help me.
I'm using three GCX's, and a LiquidFoot Pro. I've sent the F0 code to use different CC# on the GCX's. That works fine.
It does turn the active light on, and it stays on. It that correct?

I've made a function in the LiquidFoot which turns the 8 loops on the first 2 GCX's off.
So:
midi CC# 80 - 0
midi CC# 81 - 0
until
midi CC# 95 - 0
Sometimes when I press this function some loops stay on, or loops which were off turn on... Do you know what's the problem here?
Any help is apreciated! Thank you!

Author:  JohnClark [ Tue Aug 29, 2017 3:03 pm ]
Post subject:  Re: Multi GCX loops turning on and off problem

The Active LEDs staying on is good. That tells us that all the GCXs in the system got the SysEX message and are ready to rock.

If GCX loops that are already OFF are turning ON when you send this set of Control Changes with a Data Value of 0 then that there might be conflicting messages also being sent or just corrupt data being sent. A GCX Loop shouldn't turn on until it sees a Data Value 64 or above.
Do you have access to a computer running any sort of MIDI monitor software to see exactly what messages are coming from your controller?

Author:  roybeukers [ Wed Aug 30, 2017 9:27 am ]
Post subject:  Re: Multi GCX loops turning on and off problem

Hi John,

again, thank you for your answer. I checked the messages using my midiman. The controller sends out exactly what it should. The right CC with the right value. When I hooked the GCX's up to the midiman's output everything worked fine. I couldn't get an error.
Without the midiman 4 out of 5 times there is an error.
Its no problem puting something like a midiman or simmilar thing in between, so I gues that's the best option right?

Author:  JohnClark [ Wed Aug 30, 2017 9:34 am ]
Post subject:  Re: Multi GCX loops turning on and off problem

That is certainly interesting!

How long of a MIDI cable are you running from your controller to the first MIDI device?

Author:  roybeukers [ Wed Aug 30, 2017 3:58 pm ]
Post subject:  Re: Multi GCX loops turning on and off problem

1,5 meter, so that's pretty short. It's not a new cable. Could that be the problem?
I've also changed the order of the GCX's, and it does the same thing but on a different GCX. And I've also tested the output of the controller by using the "long" cable, because I used a short 20cm cable before to test it, and the right messages are showing up. A bit weird, but it works now :)

Author:  JohnClark [ Wed Aug 30, 2017 4:13 pm ]
Post subject:  Re: Multi GCX loops turning on and off problem

I was looking for was any reason that the MIDIMan was acting like a sort of buffer amp for a possible weak MIDI signal. If the cable was incredibly long (like if it was over say 15 Meters) then that may have explained what you are seeing. But clearly that isn't the case here.

Although, if you have not tried the same test with just any other MIDI cable, I'd suggest doing that straight away, it is certainly worth a look.

If it still behaves the same, maybe you could send a screen-shot from your MIDI Monitor software of the MIDI data directly from the controller, and a second one of the MIDI data after the MIDI Man. You can send pictures to info@voodoolab.com rather than trying to post them here. Also, what MIDI Monitor program are you using?

Page 1 of 1 All times are UTC - 8 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/