Current doubler for HX stomp not working

Exchange tips and tricks to help you design the ultimate pedalboard.
Post Reply
yebdox
Posts: 2
Joined: Fri Nov 12, 2021 10:00 am

Current doubler for HX stomp not working

Post by yebdox » Mon Sep 19, 2022 11:53 am

Hope someone here knows the answer to my problem.

I'm trying to build a smaller pedalboard ( Dingbat medium) with fewer pedals feeding through an HX Stomp. I have a Voodoo Labs Mondo 8 for my main power supply mounted underneath and for a few months, one of the standard current doubler cables worked fine, running 2 9V outputs at 400 MA into the Stomp, but a month or so ago, I began getting weird clicks and pops with galloping repeats when changing patches and have been trying to troubleshoot this with Line 6.

I sent it in and they replaced the motherboard, although they couldn't find anything wrong with it. I was still having the issue and they noticed from my videos that I was using the Voodoo labs current doubler cable. I switched to the Line 6 wall wart and it has been stable for a week or so, without the galloping noises. I'm waiting for a response from them (good tech support, usually quick to respond), but imagine they will just have an official stance that we should only use the supplied power, which is a problem, as everyone knows how big that wall work is and the problems with trying to route it under a smaller pedalboard.

I have gone to the Internet about this, and can't seem to find any More specific information, other than that a lot of people have been using this method, apparently with some success, which is why I tried it in the first place.

The power input on the Stomp says it requires 9V at 3A, so perhaps the current doubler doesn't add up with 2 400 mA outputs, yet everyone seems to suggest that this cable, along with these power outputs from any of the appropriate Voodoo labs power supplies should be sufficient.

Does anyone have any deeper knowledge on this ? Thanks in advance.

gdhi11
Posts: 6
Joined: Fri May 15, 2015 2:05 pm

Re: Current doubler for HX stomp not working

Post by gdhi11 » Mon Sep 26, 2022 6:55 am

You need at least 1000 MA to run it safely in my experience. The majority of the power draw is at bootup--so if you make it past that you may see weird glitchy stuff. You're just shy of the number so I would switch back to using the L6 supply until you can work out how to feed it 1000 MA.

Post Reply