Bad Adhesive on Velcro Strips

Exchange tips and tricks to help you design the ultimate pedalboard.
Post Reply
juniormarbles
Posts: 3
Joined: Tue Aug 29, 2017 12:52 am

Bad Adhesive on Velcro Strips

Post by juniormarbles » Fri Feb 22, 2019 7:54 pm

I own two Dingbat pedal boards - small and medium. I love the quality, design, and intelligent layout of these boards.

However, the backing adhesive used on the Velcro rolls provided is flawed: once cut to size, and placed on the 4 bottom corners of the pedals (each ca. 2" long), the adhesive side on the Velcro strips smears off from its original position on the pedal, which gradually slides off - especially when the pedal board case is stored on its side.

The Velcro strips stay nicely attached to their Velcro counterpart mounted on the board, so the Velcro function is obviously not a problem-but their exposed adhesive sides, once the pedal has wandered off, attract dirt. I keep sticking the strips back on the pedals where they used to be, but the problem repeats.

The Velcro adhesive is either too soft for this job, or made of the wrong formula.

Are you aware of this problem? Have you found a solution?

JohnClark
Posts: 7216
Joined: Tue May 05, 2009 2:33 pm
Location: The Lab

Re: Bad Adhesive on Velcro Strips

Post by JohnClark » Mon Mar 04, 2019 5:27 pm

I've seen adhesive do this when it gets relatively hot, like left in the car on a hot day maybe... but I have not seen this with any of our boards like what you are describing. We even have a demo board that does spend most of its life standing up in its case and nothing has moved on it in over a year.
Are you only having this trouble on the pedals, but not on the part stuck onto the pedalboard?

Please feel free to write to info@voodoolab.com so we can at least get on sending some replacements. ...and maybe you could include some pictures if you don't mind?

juniormarbles
Posts: 3
Joined: Tue Aug 29, 2017 12:52 am

Re: Bad Adhesive on Velcro Strips

Post by juniormarbles » Tue Mar 05, 2019 11:01 am

Thanks for responding. The issue of the wandering Velcros does not affect my single-width pedals, only the double and slightly larger ones, like POG, Klone, Reverbs, etc.

I think my mistake was not to cover the whole width - across top and bottom- of the pedals' underside, rather than the four corners. (The 4 strips mounted across top and bottom of the two levels on the board always stayed put.)
Thank you for providing additional Velcro material. I will re-apply the strips, and report back.

Post Reply