It is currently Thu Nov 23, 2017 1:34 pm

All times are UTC - 8 hours [ DST ]





Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Mondo Inducing Hum
PostPosted: Sun Jun 18, 2017 5:43 pm 
Offline

Joined: Sun Jun 18, 2017 5:35 pm
Posts: 1
I've got a brand new Mondo mounted under a Pedal Train board, and I've discovered that if I put my Boss NS-2 or Radial Bones Twin City on top of it on the pedal board, I get hum. Pull them a few inches away and it disappears. Anyone else have this problem? Any easy fixes? Prior to the Mondo I had a Pedal Power 4X4 with no issues. Is it a larger transformer in the Mondo? The fan? I can't really have that much space on my pedalboard as no man's land. I hate to have to find pedals that don't hum and put them there, because I have a comfortable order I've used for years. Will if I have to. Is this an issue with other power units (Strymon, etc.)? Hoping maybe there's a simple solution.


Top
 Profile  
 
 Post subject: Re: Mondo Inducing Hum
PostPosted: Tue Jun 27, 2017 3:02 pm 
Offline

Joined: Tue May 05, 2009 2:33 pm
Posts: 6760
Location: The Lab
Sorry for the late reply!

Is there any possibility of moving the Mondo mounting position? Which PedalTrain board do you have?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: Bing [Bot] and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: