It is currently Fri Nov 24, 2017 7:48 am

All times are UTC - 8 hours [ DST ]





Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Gain issue with Pedal Power 2+
PostPosted: Sat Oct 31, 2009 3:03 pm 
Offline

Joined: Sat Oct 31, 2009 2:56 pm
Posts: 3
Just noticed how much gain my pedal board introduces to my signal with the Pedal Power 2+. If I plug straight into my amp, the tone is significantly less fizzy/distorted. Anybody else had any issues with this? Anything to do with the DIP switches? Help would be appreciated.


Top
 Profile  
 
 Post subject: Re: Gain issue with Pedal Power 2+
PostPosted: Sun Nov 01, 2009 2:05 pm 
Offline

Joined: Fri May 15, 2009 3:08 am
Posts: 117
Location: New Zealand!
List your signal chain and what outlets you are using to power the effects. It could be a number of things...........

_________________
Connoisseur of good tone.

http://www.john-trueman.com : Guitarist from Down Under
http://www.guitarpedals.co.nz


Top
 Profile  
 
 Post subject: Re: Gain issue with Pedal Power 2+
PostPosted: Sun Nov 01, 2009 3:09 pm 
Offline

Joined: Sat Oct 31, 2009 2:56 pm
Posts: 3
BOSS TU-2>Catalinbread Silver Kiss>MXR micro amp>Rockman optical volume pedal>MXR Phase 90>Line 6 DL4 out to amp.

The Silver Kiss and micro amp are powered by the SAG channels, with the DIP switches on NORMAL.
The rest of the pedals, except the DL4 are in the standard inputs 1-4, NORMAL.
I have the DL4 in ouput '5'--but switched to 'NORMAL' as opposed to 'ON'...maybe this is the problem? I just noticed the manual indicates it should be on.
Otherwise, the Rockman is powered by a homemade cable (no problems before)...but the output is switched to 'NORMAL'/'OFF'. Maybe it should be 'ON', too?
Thoughts?


Top
 Profile  
 
 Post subject: Re: Gain issue with Pedal Power 2+
PostPosted: Mon Nov 02, 2009 4:46 pm 
Offline

Joined: Tue May 05, 2009 2:33 pm
Posts: 6760
Location: The Lab
The DL4 should be powered from either Output 5 or 6 with the DIP switch set away from Normal. Do you have any reliable information on what the Rockman's power requirements are?


Top
 Profile  
 
 Post subject: Re: Gain issue with Pedal Power 2+
PostPosted: Tue Nov 03, 2009 11:44 am 
Offline

Joined: Sat Oct 31, 2009 2:56 pm
Posts: 3
I've switched the DL4 to the 'ON' position.
As for the Rockman RV-1 optical volume: it's 9V DC powered with a centre-positive pin--the slightly larger barrel size, I believe.
Although, despite being plugged in correctly, I think the nasty distortion might actually be originating from the DL4: without it in the chain, the distortion is gone. All the other pedals seem to check out fine.
Sounds like the DL4 is still underpowered. Any other thoughts, or do I just need to get the pedal serviced? Otherwise, it's operating fine.


Top
 Profile  
 
 Post subject: Re: Gain issue with Pedal Power 2+
PostPosted: Tue Nov 03, 2009 5:00 pm 
Offline

Joined: Tue May 05, 2009 2:33 pm
Posts: 6760
Location: The Lab
One can never go wrong with trying each pedal out on its own in order to determine if a single pedal is the culprit. Does the DL-4 perform properly when it is the only pedal in the signal path and the only pedal being powered?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: Bing [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: