Voodoo Lab
http://www.voodoolab.com/forum/

EP103 Echolplex Delay
http://www.voodoolab.com/forum/viewtopic.php?f=7&t=7235
Page 1 of 1

Author:  bunzai1 [ Thu Dec 01, 2016 2:43 pm ]
Post subject:  EP103 Echolplex Delay

Just got this pedal, an Echoplex ep103 delay. Plugged it into my Pedal Power 2Plus 9v outlet and the pedal does not function. Contacted Dunlop, and they said I needed to use the supplied adapter, i.e. the pedal was not getting enough power. It needs 9V 240 mA to run. Any way to run this off the PP2+ the power supply? Any help would be appreciated. Thanks

Author:  JohnClark [ Thu Dec 01, 2016 3:13 pm ]
Post subject:  Re: EP103 Echolplex Delay

The Dunlop EP103 Echoplex Delay can be powered from a Pedal Power 2+ on output 5 or 6 with the corresponding DIP switch set to Normal using one of the included all black standard barrel cables.

I hope that helps!

Author:  jimmyw [ Fri May 19, 2017 7:57 am ]
Post subject:  Re: EP103 Echolplex Delay

JohnClark wrote:
The Dunlop EP103 Echoplex Delay can be powered from a Pedal Power 2+ on output 5 or 6 with the corresponding DIP switch set to Normal using one of the included all black standard barrel cables.

I hope that helps!


The above doesn't work for me. Tried it in either 5 or 6 (with DIP in Normal position) and got crickets... Only solution for me is using the Dunlop provided power supply into the courtesy jack of my PP2+. Not a deal breaker for me but I'm puzzled as to why it doesn't work for me. :o

Author:  JohnClark [ Fri May 19, 2017 11:37 am ]
Post subject:  Re: EP103 Echolplex Delay

jimmyw wrote:
JohnClark wrote:
The Dunlop EP103 Echoplex Delay can be powered from a Pedal Power 2+ on output 5 or 6 with the corresponding DIP switch set to Normal using one of the included all black standard barrel cables.

I hope that helps!


The above doesn't work for me. Tried it in either 5 or 6 (with DIP in Normal position) and got crickets... Only solution for me is using the Dunlop provided power supply into the courtesy jack of my PP2+. Not a deal breaker for me but I'm puzzled as to why it doesn't work for me. :o


Hmm, it should work just fine, the max draw is stated to be 240mA. We have even seen a setup with an EP103 and a M300 Reverb on 5 and 6 at the same time with no trouble.
Does it work if it is the only pedal connected? What else are you powering? Did you check that it isn't a failing power cable? Do you maybe have the Pedal Power 2, not the 2+?

Author:  jimmyw [ Sun May 21, 2017 7:52 pm ]
Post subject:  Re: EP103 Echolplex Delay

JohnClark wrote:
jimmyw wrote:
JohnClark wrote:
The Dunlop EP103 Echoplex Delay can be powered from a Pedal Power 2+ on output 5 or 6 with the corresponding DIP switch set to Normal using one of the included all black standard barrel cables.

I hope that helps!


The above doesn't work for me. Tried it in either 5 or 6 (with DIP in Normal position) and got crickets... Only solution for me is using the Dunlop provided power supply into the courtesy jack of my PP2+. Not a deal breaker for me but I'm puzzled as to why it doesn't work for me. :o


Hmm, it should work just fine, the max draw is stated to be 240mA. We have even seen a setup with an EP103 and a M300 Reverb on 5 and 6 at the same time with no trouble.
Does it work if it is the only pedal connected? What else are you powering? Did you check that it isn't a failing power cable? Do you maybe have the Pedal Power 2, not the 2+?


LOL! With my PP2+ mounted, I was counting backwards... Trying to use 4 instead of 5. After correctly inserting the cable into 5, it works. Thanks!

Page 1 of 1 All times are UTC - 8 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/