Voodoo Lab
http://www.voodoolab.com/forum/

400mA into 100mA?
http://www.voodoolab.com/forum/viewtopic.php?f=7&t=7134
Page 1 of 1

Author:  claxor [ Sat Oct 08, 2016 11:03 am ]
Post subject:  400mA into 100mA?

Can I safely power a pedal that's 9VDC @ 100mA by using a 9VDC @ 400mA connection on the ISO 5 pedal power, or will it hurt the 9VDC @ 100mA pedal?

Thanks!

Author:  JohnClark [ Tue Oct 11, 2016 9:36 am ]
Post subject:  Re: 400mA into 100mA?

No problem at all!

A pedal will only draw the amount of current it needs to operate so it is perfectly safe to power a low current draw pedal from the High Current output on the ISO-5.

I hope that helps!

Author:  Winged_Sentinel [ Tue Mar 28, 2017 2:43 pm ]
Post subject:  Re: 400mA into 100mA?

Good to read that this works, but it seems that for me, pedals that draw 9VDC @ 100mA aren't drawing any power from the 9VDC @ 400mA output (though they seem to be drawing from the other 9V outputs just fine). Is this a common problem? Do I need to be running a different type of cable?

Author:  JohnClark [ Thu Mar 30, 2017 9:47 am ]
Post subject:  Re: 400mA into 100mA?

Winged_Sentinel wrote:
Good to read that this works, but it seems that for me, pedals that draw 9VDC @ 100mA aren't drawing any power from the 9VDC @ 400mA output (though they seem to be drawing from the other 9V outputs just fine). Is this a common problem? Do I need to be running a different type of cable?


No sure why that would be... what power supply are you using? What pedals are you using?

Page 1 of 1 All times are UTC - 8 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/