400mA into 100mA?

General discussion and tech talk about the industry standard Pedal Power line of power supplies.
Post Reply
claxor
Posts: 9
Joined: Wed Mar 04, 2015 6:24 pm

400mA into 100mA?

Post by claxor » Sat Oct 08, 2016 11:03 am

Can I safely power a pedal that's 9VDC @ 100mA by using a 9VDC @ 400mA connection on the ISO 5 pedal power, or will it hurt the 9VDC @ 100mA pedal?

Thanks!

JohnClark
Posts: 7079
Joined: Tue May 05, 2009 2:33 pm
Location: The Lab

Re: 400mA into 100mA?

Post by JohnClark » Tue Oct 11, 2016 9:36 am

No problem at all!

A pedal will only draw the amount of current it needs to operate so it is perfectly safe to power a low current draw pedal from the High Current output on the ISO-5.

I hope that helps!

Winged_Sentinel
Posts: 1
Joined: Tue Mar 28, 2017 2:38 pm

Re: 400mA into 100mA?

Post by Winged_Sentinel » Tue Mar 28, 2017 2:43 pm

Good to read that this works, but it seems that for me, pedals that draw 9VDC @ 100mA aren't drawing any power from the 9VDC @ 400mA output (though they seem to be drawing from the other 9V outputs just fine). Is this a common problem? Do I need to be running a different type of cable?

JohnClark
Posts: 7079
Joined: Tue May 05, 2009 2:33 pm
Location: The Lab

Re: 400mA into 100mA?

Post by JohnClark » Thu Mar 30, 2017 9:47 am

Winged_Sentinel wrote:Good to read that this works, but it seems that for me, pedals that draw 9VDC @ 100mA aren't drawing any power from the 9VDC @ 400mA output (though they seem to be drawing from the other 9V outputs just fine). Is this a common problem? Do I need to be running a different type of cable?
No sure why that would be... what power supply are you using? What pedals are you using?

Post Reply