It is currently Mon Nov 20, 2017 4:09 pm

All times are UTC - 8 hours [ DST ]





Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Trouble powering Mobius and Timeline
PostPosted: Thu Mar 07, 2013 9:24 pm 
Offline

Joined: Thu Mar 07, 2013 9:20 pm
Posts: 1
I own the pedal power 2 plus. The manual for both pedals says it runs on no more than 9vdc which each outlet on the supply has. When I plug it in the pedals act like they try to start up but just can't. Yet my King of Tone and other pedals work just fine. So lately I've just been using the power supplies for the pedals.

Is this normal?


Top
 Profile  
 
 Post subject: Re: Trouble powering Mobius and Timeline
PostPosted: Mon Mar 11, 2013 12:33 pm 
Offline

Joined: Sat Dec 08, 2012 1:27 pm
Posts: 187
Location: Irvine, CA
Are you using a current doubling cable for them? Both the Mobius and Timeline require 9V 300mA, so no single PP2+ output will supply enough current to work. You'll need to combine output 5 and one other 9V output for one of the pedals, and output 6 plus one other 9V output for the other using the current doubling cables.
Hope that helps.

_________________
Julian Shur
Pedal Junkie/Amateur Circuit Barber


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: