Powering a JHS Emperor v2

General discussion and tech talk about the industry standard Pedal Power line of power supplies.
Post Reply
jacla
Posts: 4
Joined: Tue Sep 03, 2019 5:58 am

Powering a JHS Emperor v2

Post by jacla » Tue Sep 03, 2019 6:21 am

Hey,

I recently got a Voodoo Lab Power Plus 2 and set up with my board, everything was running fine aside from my JHS Emperor v2 (https://www.sweetwater.com/store/detail ... -tap-tempo). After a couple of minutes I start getting a very loud hum noise from the pedal when switched on. I have ran this pedal through a Diago daisy chain prior to this and worked fine.

Using Output 1 (9v, 100mA) with the pedal being centre negative I assumed this would be an adequate set up but the loud booming noise when the pedal is engaged tells me not.

Aside from this potentially being a broken DC power cable, using the incorrect cable or a faulty pedal - is there anything here i'm missing? Have tried again with the daisy chain and was fine to use, totally stumped on this one.

Appreciate your time.

Thanks!

Rez
Posts: 401
Joined: Thu Sep 01, 2011 10:31 am

Re: Powering a JHS Emperor v2

Post by Rez » Tue Sep 03, 2019 12:18 pm

Indeed, it should work fine as you describe:

To power the JHS Emperor V2 with Pedal Power 2 Plus use any 9VDC output with one of the all black (standard polarity) cables supplied.

Have you tested it from other 9V outputs on the power supply? Try specifically from output 5 or 6 (in the normal 9V DIP switch setting), any better?


Also, if you physically move the pedal does this affect the noise?
Cheers,
Ben Resnick
Voodoo Lab - Tech Support

jacla
Posts: 4
Joined: Tue Sep 03, 2019 5:58 am

Re: Powering a JHS Emperor v2

Post by jacla » Thu Sep 05, 2019 1:59 am

Hey Rez, thanks once more!

I tried this again last night with a separate power supply (9.6v, 200mA, Centre Negative) that I got with my EHX Pitchfork and worked fine. This wasn't through the whole chain though.

I think i'll have to put this down to a broken power lead or (hopefully not) power output and will 5/6.

Moving the pedal doesn't effect the sound.

Thanks again!
Jac

Rez
Posts: 401
Joined: Thu Sep 01, 2011 10:31 am

Re: Powering a JHS Emperor v2

Post by Rez » Thu Sep 05, 2019 3:09 pm

Indeed.

If it turns-out to be a problem with a cable or the supply itself...

Please, call us or send us an email ( info@voodoolab.com ) we are glad to arrange for its inspection and repair.

Cheers!
Cheers,
Ben Resnick
Voodoo Lab - Tech Support

Post Reply