Pedal Power 2 unit and EVH Chorus Pedal

General discussion and tech talk about the industry standard Pedal Power line of power supplies.
Post Reply
Bradjr5150
Posts: 1
Joined: Tue Jun 29, 2021 1:54 pm

Pedal Power 2 unit and EVH Chorus Pedal

Post by Bradjr5150 » Tue Jun 29, 2021 2:18 pm

Hello,

I been trying to connect my EVH Chorus to the pedal power unit. It appears that the MXR EVH pedal will only light up full color and sound good when using the 5 or 6 input of the pedal power....... when I tried the 1-4 inputs on the pedal power something was just not right the chorus effect was harsh and overdriven on my clean channel.

But since I now have the 5 input powering the chorus pedal it sounds right... no OD and a high quality chorus effect.

I just hope this is safe for the MXR Chorus pedal.... I have the small tiny white switch set to normal on input 6 and my EVH Chorus is 9 volt. Spec below:
Power Source: 9V DC power supply required (sold separately)
Power Usage: 95mA

So according to the manual power inputs 1-4 have up to 100 MA and 5 & 6 have up to 250 MA. I wonder why the chorus has issues when I use the 1-4 but not 5 or 6?

Can someone help me with this?

Marlboro05
Posts: 262
Joined: Mon Sep 07, 2015 12:46 pm
Location: Australia

Re: Pedal Power 2 unit and EVH Chorus Pedal

Post by Marlboro05 » Wed Jul 07, 2021 9:11 pm

Hi there,
It should run fine from any of the outlets, does it run alright with the battery? Maybe give this a go, if it doesn’t, it may have something wrong with it.

Do other pedals, reverb etc. run fine in the outlets 1-4 and 7 & 8?
GCPro, GCX, Pedal Power 2+, Pedal Power AC.
And some other stuff.

Rez
Posts: 675
Joined: Thu Sep 01, 2011 10:31 am

Re: Pedal Power 2 unit and EVH Chorus Pedal

Post by Rez » Fri Jul 30, 2021 4:10 pm

Indeed, as suggested it should work fine from any of the outputs (in the 9V setting).

Cheers!
Cheers,
Ben Resnick
Voodoo Lab - Tech Support

drolaw
Posts: 13
Joined: Mon Feb 25, 2013 1:54 pm

Re: Pedal Power 2 unit and EVH Chorus Pedal

Post by drolaw » Sun Jan 09, 2022 9:35 pm

I'm having the same problem. I am using a pedal power 2 and it won't fully power the MXR EVH chorus pedal. Having lived in Europe it's like bringing an amp with 220v and trying to use it with our 110/120v outlets.

I had the MXR analog Chorus connected to slot 4 on my GCX and powered by the pedal power 2. Never had any problems. As soon as I switched out the pedal for the EVH Chorus I noticed only a little blue light signalling it's not getting the proper power.

Both MXR pedals require 9v and the polarity is the same - still scratching my head on why I'm experiencing this.

I tried my old Boss 9v power adapter and it powered the EVH Chorus perfectly. I also tried it with a new 9v battery and it worked fine.

I reconnected the MXR analog chorus back and it works perfectly. I tried other slots on the power pedal and still had the issue with the EVH Chorus.

Weird...anyone else have this problem and was able to solve it?

Rez
Posts: 675
Joined: Thu Sep 01, 2011 10:31 am

Re: Pedal Power 2 unit and EVH Chorus Pedal

Post by Rez » Mon Jan 24, 2022 6:31 pm

Perhaps it actually wants a bit more than the 95mA specified.

If you've got Pedal Power 2 Plus (and not the older Pedal Power 2), maybe try it in output 5 or 6, DIP switch in the 9V (normal) setting... any better?
Cheers,
Ben Resnick
Voodoo Lab - Tech Support

Post Reply